投稿

ラベル(ipv6)が付いた投稿を表示しています

家の中のPC同士をIPv6アドレスで通信してみた。

JUGEMテーマ: インターネット 旬っぽいので。 国家のITの礎は家庭のITから! というほどのことでもなく、無線LANルータに家長の座を譲り渡し、 生来IPv4アドレスをもっているせいで(明示的なL2スイッチ化機能が無い) 馬鹿Hubにもなりきれず眠っていたIO DATAのNP-BBRPを有効活用したかったのでやってみた。 試したかったこと: ネットワークインターフェースにIPv4ふらなきゃ このBBルータのv4アドレス無視してIPv6のテストに使えるんじゃね? 用意するもの ・OpenBSDのPC(イーサネット1つ) ・LinuxのPC Ubuntu(イーサネット1つ) ・LANケーブルストレート 2本 ・要らなくなった有線ルータ(100Mbps LAN側に口4つ、WAN側に1つ) ��Solaris同士でもLinux同士でもBSD同士でも別に構わない。 ■設定 - BSD側 ネットワークIFカードにfec0::1とfec0::2だけを割り当てる ��anycastアドレスが必須というわけでもない) ifconfigを実行してネットワークIFカードのタイプ(<if>)を確認する /etc/hostname.<if> ファイルを以下のように書き換える。 inet6 alias fec0::1 64 inet6 alias fec0::2 64 anycast ��ほぼ man hostname.if の例のままなわけだが・・・) ネットワークを再起動する # sh /etc/netstart 再びifconfigを実行して リンクローカルアドレスの下に以下のように追記されていることを確認する inet6 fec0::1 prefixlen 64 inet6 fec0::2 prefixlen 64 anycast ping6で自分にPingが通るか確認する # ping6 ::1 (ローカルループバック) # ping6 fec0::1 - Linux側 $ ifconfig eth0 inet6アドレス: の箇所に自分のIPv6リンクローカルアドレス(fe80:で始まるやつ) だけがついていることを確認。別にこのアドレスを使うわけじゃない。 ここで eth0に アドレス fec0::3 Prefix 64 を割り当てる。...

IPv6のアドレス種類

イメージ
以前FreeMindで作成したまとめ 全然はやりませんね。そのうちIPv4と互換・共存可能な次世代IPプロトコルがでてきそうな予感。

lighttpdでIPv6 を使う設定

make時にはIPv6Supportは有効だが、 実際にIPv6のアドレスで待ち受けられるようにするには .confファイルに以下の行を追加する。 ��最近のDistributionでどうなっているかは不明。 OpenBSD4.0/lighttpd 1.4.18 野良インスト) server.use-ipv6 = "enable" 書き換えたら再起動 # ps aux | grep lighttpd -> PIDを探す # kill -9 みつけたPID # lighttpd -f confファイル このあたりはパッケージによってはスマートな方法があると思う。 ああでもそうするとv4でListenしなくなった。どうすりゃいいのだ? 本家にのってますた。 http://trac.lighttpd.net/trac/ticket/509 itojunのRFCdraftがどうのこうのいってるけど server.use-ipv6 = "enable" server.port = 80 $SERVER["socket"] == "0.0.0.0:80" { # listen on all ipv4 interfaces. } これでいけた。 JUGEMテーマ: インターネット で、なんでこんな日記書いたかというと、undeadly.orgの記事に N2K8 Hackathon Summary Part 1 浴衣姿のTheo様。あーんテオ様(略)、じゃなかった IPv6 Support in httpd(8) httpd(8)がIPv6サポというニュースがあったから。 いい加減アップグレードせんとなあ。新しいマシンほすい。

IPv6 事始め

JUGEMテーマ: インターネット 手元のWindows XPでIPv6を有効化する方法やツールについてのFAQなど Windows XP IPv6 プロトコルに関する FAQ 何はともあれ。IPv6開始 ipv6 install ipconfig の出力内容がかわる。 インターフェースの状態は ipv6 ifで確認する ipv6 if %SystemRoot%¥Help¥ipv6.chm も、すぐに参照できるようにしておこう。 通常はC:¥WINDOWS¥Helpにあるはず。 Word形式だが大体同じものがまとめられている。 Microsoft Windows - IPv6 • IPv6 に対するマイクロソフトの目標 • IPv6 概説 • IPv6 と IPv4 の共存および移行 • IPv6 の構成とテスト ラボ • Windows Sockets アプリケーションへの IPv6 機能の追加 つうかなんだこのXPのHELPの至れり尽くせり具合は。。。基本的な勉強は このCHMだけでいいんじゃねえか? 「一人WindowsXPで学ぶIPv6」 作戦を開始することにする。

IPv6 事項

http://www.jp.netbsd.org/ja/docs/network/ipv6/index.html IPv6 Networking FAQ より * 自動設定。 IPv4 では DHCP がありますが、これはオプションです。 DHCP サーバーのないサイトにやってきた初心者にとっては、 問題があるかもしれません。 IPv6 では、「ステートレスホスト自動設定 (stateless host autoconfiguration)」の仕組みが必須です。 これは、 IPv4 の DHCP よりも簡単に使ったり管理したりできます。 この仕様は RFC2462 で決められています。 * セキュリティー。 IPv4 では IPsec はオプションであり、相手が IPsec に対応しているかを たずねる必要がありました。 IPv6 では、 IPsec への対応が必須です。 IPsec を必須にすることで、 IPv6 のデバイスと通信している限りは、 安全な IP 通信ができます。 * トラフィック工学技術への適応。 IPv6 は、 diffserv や intserv (RSVP) といったトラフィック工学によりよく対応できるように設計されました。 我々はまだ、トラフィック工学のための単一の標準を手にしていません。 それゆえ、 IPv6 基本仕様では、そのような技術にそなえてヘッダー領域に 24 ビットの空間を確保しておくことで、 IPv4 よりもすばらしい来たるべき標準 になることができます。 * マルチキャスト。 マルチキャストは IPv4 ではオプションでしたが、 IPv6 では必須です。 IPv6 の基本仕様それ自体が、マルチキャストを広く使っています。 * アドホックなネットワーキングへの、よりよい対応。 スコープ付きアドレスにより、アドホックな (あるいは「設定不要な」) ネットワーキングへの、よりよい対応ができます。 IPv6 はエニーキャストアドレスにも対応しており、 サービスの探索にも役立ちます。 * さらにいろいろ。 RFCを抽出 RFC1550 IP: Next Generation (IPng) White Paper Solicitation RFC2460 Internet Protocol, Version 6 (IPv6)...